NAS, 1,5TB RAID1 und Begeisterung …

Vorige Woche hat ja unerwarteterweise mein Homeserver die Grätsche gemacht (eigentlich nur dessen Festplatte, aber das sei mal dahin gestellt). Das ich darüber nicht sonderlich erfreut war, das kann sich wohl jeder von euch denken :(. Was solls – es musste also was brauchbares neues her. Nachdem ich meine Auswahlliste (besser gesagt die unserer Lieferanten) durchgeklaubt hatte, blieben 5 NAS-Gehäuse übrig. Da ich aber auch nicht hinterm Mond lebe, habe ich natürlich nach allen Gehäusen gegoogelt und so herausgefunden, dass einige eine sehr bescheidene Performance haben, die anderen nicht ohne Spezialtreiber für Windows auskommen und wiederrum andere nicht mit den von mir ausgewählten Platten zusammen arbeiten wollten.

Übrig geblieben ist: Weiterlesen

Wartungsarbeiten, Zeitraffer und Video …

Einen Teil unserer Umbau- und Wartungsarbeiten konnten wir auf Video festhalten (danke Schoash):

Youtube Video:

Und als direkter Download im MP4-Format:

anexia_datacenter_rebuild_2009_01_24 (15,4MB, 2:45 Minuten)

PS: Das Video hat eine Originallänge von ca 8 Stunden und 20 Minuten. Die 2 Minuten 45 Sekunden sind also wirklich extreme Zeitraffer.

Wartungsarbeiten, Ausfall, Hardware und ein paar Nerven …

So, wie alle sehen können ist mein Blog nun endlich wieder online. Auch die Seiten einiger User, die ich noch hoste, sind wieder erreichbar. Der angekündigte Umzug innerhalb des Rechenzentrums und die Auflassung des alten Standorts liefen zu ca 98% ohne Fehler ab. Die restlichen 2% wurden von inkonsistenten RAID-Systemen, defekten Netzteilen und einem einzigen defekten Mainboard abgedeckt.

Ratet mal welches Mainboard einen Defekt hatte?! Richtig – das meines Hauptservers. Und wie es der Fehlerteufel so wollte, war es kein einfacher Defekt sondern eine recht beschissene bescheidene Angelegenheit, die ich persönlich noch nie bei einem Mainboard hatte: das CMOS war defekt. Auch ein Neuflashen des CMOS half nichts – heute habe ich das Board eingeschickt, nachdem ich bereits Ersatz erhalten habe und mein Server nun wieder läuft.

Die Aktion hat mich doch ein paar Nerven und einige graue Haare gekostet. Ich bin beruhigt, dass hier nun auch wieder alles läuft ;).

Wartungsarbeiten, Unterbrechung und viel Hardware …

Ich bin so frei und zitiere einfach mal die Mail, die wir vorige Woche auch an alle Kunden gesendet haben:

Sehr geehrter Kunde,
sehr geehrter Partner!

Aufgrund der stetigen Erweiterungs- und Anpassungsarbeiten im Bereich
unserer Infrastruktur freut es uns Ihnen folgendes mitteilen zu können:

Seit einigen Tagen ist ein weiterer Teil des ANEXIA Rechenzentrums #2
fertiggestellt und für den aktiven Betrieb bereit. In diesem Bereich werden wir in den nächsten Wochen und Monaten unsere gesamte Infrastruktur migrieren und damit auch einige Fehlerquellen beseitigen, die uns in letzter Zeit leider immer wieder kleinere Probleme bereitet haben.

Aus logistischen und technischen Gründen werden wir unseren neuen
Backbone auch in diesem Bereich des Rechenzentrums aufbauen. Für Sie
wird es in Zukunft also den gewohnten Standard geben:

#) Redundante Anbindung an unseren Backbone
#) Vollständige Redundanz wichtiger Routingknoten
#) Redundante Klimatisierung
#) Klimatisierter Doppelboden (min. 30cm hoch)
#) Getrennte Kabeltrassen für Strom- und Datenleitungen
#) Brand-Früh-Erkennung
#) Temperaturüberwachung
#) Drei von einander unabhängige USV-Phasen
#) Zwei von einander unabhängige Netz-Phasen
#) Biometrische Zugangskontrollen
#) Videoüberwachung

Leider ist es auch uns nicht möglich solche massiven Umbauarbeiten ohne
Ausfallszeiten abzuwickeln. Wir teilen Ihnen hiermit folgende
Wartungsfenster mit:

Samstag, 24.01.2009, Beginn: 00:00 Uhr
Samstag, 24.01.2009, Ende:   07:30 Uhr

Sonntag, 25.01.2009, Beginn: 00:00 Uhr
Sonntag, 25.01.2009, Ende:   07:30 Uhr

In dieser Zeit kann es zu partiellen Netz- und Systemausfällen kommen.
Aus Sicherheitsgründen bitten wir Sie bei kritischen Systemen eine
Datensicherung durchzuführen (sofern diese Systeme nicht von uns
verwaltet sind).

Sollten Sie bei uns einen dedizierten Windows-Server haben, bitten wir Sie dieses System vor dem jeweiligen Wartungsfenster herunter zu fahren. Ihr System wird nach den Wartungsfenster automatisch hochgefahren.

Bitte deaktivieren Sie für die oben angeführten Wartungsfenster auch sämtliche Cronjobs und Monitoringssysteme, um Datenverlust und Falschmeldungen zu verhindern.

Vielen Dank für Ihr Verständnis.

Was das für das Blog hier bedeutet sollte jedem klar sein: es wird ab heute Abend kurzfristig nicht zur Verfügung stehen ;).

Homeserver, RAID, Backup und Recovery …

Hachja. Ich bin gerade so richtig gut gelaunt. Naja, fast. Bei meinem Homeserver ist gestern eine Kernel Panic aufgetreten und ich hatte erst heute Zeit mir die Sache näher anzusehen. Tja, wie soll ich sagen:

sda: Current: sense key: Medium Error

Additional sense: Unrecovered read error – auto reallocate failed

[…]

end_request: I/O error, dev sda, sector 47077903

[…]

SCSI device sda: read seek error

[…]

SCSI device sda: spin down device

Jup, das war es also mit meiner letzten privaten WD Raptor 74GB mit 8MB Cache – ich hatte 4 davon, jede einzelne hat die Grätsche gemacht :(. 2 mit jeweils 16MB Cache laufen dafür wie am Schnürchen. Mal WD kontaktieren, ob die mir die Platte nochmal ersetzen. Achja: Datenverlust habe ich keinen erlitten, war nur die Bootplatte vom VMWare Hostsystem *puh*. Backup läuft trotzdem, Homeserver wird entweder durch ITX System (eventuell mit 4x 2,5″ Platten im RAID10) oder überhaupt durch ein kleines NAS ersetzt – muss ich zuerst durchrechnen :D.

Arbeit, Musik und Bassline …

Ich gebe es ja zu (Asche auf mein Haupt!): ich bin ein Musikjunkie … egal was ich gerade mache, ich brauche Musik sonst … sonst geht alles nur halb so schnell :D. Da ich ja eher Richtung Techno, Hardstyle, Progressive Techno, aber auch Peter Fox, Thomas D und Roger Cicero höre (Musikalisches Kaudawelsch!), bin ich im Moment auf der Suche nach einem halbwegs vernünftigem Online Radio – der Großteil derer, die ich in meinen Playlists habe, spielen im Moment entweder zu 100% Kommerz oder Happy Hardcore ( :shock:).

Also: kennt irgendjemand ein Online Radio das eher weniger Kommerz, dafür sehr gerne mal richtig geilen Hardstyle spielt? Und bitte keine Niederländer – dass was die Jungs dort Hardstyle nennen ist fast zu 90% Jumpstyle und ich bin halt leider kein Epileptiker – die Richtung ist also nicht so meins :D.

WordPress, Update und viele Fragezeichen …

Endlich habe ich mich dazu durchgerungen mein WordPress 2.6 in die Tonne zu treten und auf 2.7 upzugraden. Gut, das Upgrade dauerte keine 5 Minuten und das Admin-Panel sieht ja nun auch besser aus (und geht gefühlte 50% schneller!). Aber was ich noch immer nicht verstehe: das Backend-Theme ist teils auf Deutsch und Teils auf Englisch. Das war mir bereits in den 2.6er Versionen des DE-Themes aufgefallen. Weiß irgendjemand ob das an einem Datenbankeintrag liegt oder eventuell User-Agent abhängig ist? Das nervt mich nämlich :(.

Ansonsten bin ich bisher ganz zufrieden.

Update: Für alle die das gleiche Problem haben: einfach in den Ordner wp-content/langugages die neuen de_DE.* files einspielen, dann klappts auch mit der Sprache :D.

Ärger, Delle und noch mehr Ärger(!) …

Hier bei mir herrscht gerade sehr schlechte Laune! Ich war vorhin beim Interspar ein paar Dinge einkaufen und habe mein Auto extra weiter weg geparkt, damit ich mich nicht zwischen die ganzen alten Leute (die ja unbedingt genau zu Mittag einkaufen gehen müssen!) parken muss – das gibt nämlich hässliche Dellen! Ja ja, die Erfahrung :(. Aber es kommt doch meistens anders als man denkt: da mein Auto im Moment frisch gewaschen ist, sieht man am Lack so ziemlich jeden Fussel, Kratzer usw (zur Erinnerung: mein Auto ist weiß).

Ich komm also mit einem netten Grinsen zu meinem Auto (weil es nach 3 Wochen endlich mal wieder sauber ist) und plötzlich fällt mir so einiges aus dem Gesicht: ich habe eine frische(!) 20 cm lange Delle in der Fahrertür – inkl. Lackspuren und lädierten Klarlack. Ich könnte kotzen! Meine Idee, extra weiter weg zu parken, hat also irgendjemand dafür missbraucht, mir eine Delle ins Auto zu machen *argh*. Foto anbei – wer nichts erkennt: einfach mal die Reflexion am Lack genauer betrachten – die hat nämlich knapp unterm Seitenspiegel einen gewaltigen Knick 👿 👿 :evil:.

DIE, 20kV und ein lauter Knall …

Wir sind im neuen Bereich unseres Rechenzentrums, das Licht flackert kurz auf, wir wundern uns. Keine 5 Sekunden später erhalten wir die ersten Ausfallsmeldungen per SMS. Ich ziehe mir meine Jacke über und mache in Windeseile auf den Weg ins ANEXIA RZ #1. Es waren diverse Wartungsarbeiten im Bereich der Energieversorgung angekündigt.

2 Minuten später bin ich 100m vor dem RZ und werde bereits von Blaulichtern willkommen geheißen – die Feuerwehr ist vor Ort, eine Menschentraube bildet sich vor dem Eingang des Gebäudes. Ich suche mir einen Parkplatz in der Nähe und eile hinein – der Portier labert wirres Zeug gibt nichts Brauchbares von sich. Ich frage ob ich das Kellergeschoss betreten darf (da ja die Feuerwehr vor Ort ist): Ja, ich darf. Eine Minute später stehe ich inmitten einer Rauchschwade (im Kellergeschoss) und sehe Feuerwehrleute mit Atemschutz durch die Gegend laufen – ich ahne Böses. Vor dem Serverraum angekommen sehe ich bereits einige Kollegen anderer Firmen, die auch direkt Hardware im RZ housen. Mein Ansprechpartner wirkt verwirrt, spricht nur von einem lauten Knall und ist sichtlich beeindruckt, dass die Hütte noch steht.

Ich kontrolliere unsere Hardware: es ist kein Netzstrom mehr verfügbar und eine unserer USVs hat vermutlich aufgrund einer Überspannung die Grätsche gemacht – nachdem ich die Geräte an die andere USV angeschlossen habe, laufen auch diese wieder. Unser Routing war für ca 15 Minuten unterbrochen, weil auch LWL-Fasern einiger Carrier anscheinend nicht per USV im Aktivbereich gesichert waren.

Was war passiert? Der Energielieferant (um einen Namen zu nennen: die Kelag Kärnten) hatte im Bereich der Hauszuführungen irgendwelche Wartungs- und/oder Umschaltungsarbeiten vorgenommen. Da dürfte dann etwas nicht so ganz ohne Schmerzen vonstatten gegangen sein – es hat nämlich einen 20kV Leistungsschalter zerlegt. Der (mittlerweile nicht mehr verwirrte) Ansprechpartner von uns hat mir erzählt, dass es verdammt laut geknallt hat und plötzlich ging der Feueralarm los.

Zu allem Trotz ist heute sogar der 13. und auf der digitalen Uhr im Eingangsbereich war DIE zu lesen – stand zwar wohl für Dienstag, aber das könnte man falsch interpretieren :shock:.

Fotos gibts leider keine, weil ich eine Trantütte bin und es verpennt habe welche zu machen – eventuell mache ich von der USV die Tage mal ein Bild – da häts nämlich das Chassis zerlegt :shock:.

PS: Der Feueralarm hatte es in sich :shock:: sirene_kelag_alarm (446KB)

Adaptec, RAID und Performance …

Mir leuchtet ja viel ein – aber manches ist mir einfach zu hoch :(. Ich habe hier im Moment einen Server mit einem Adaptec 5405 RAID-Controller liegen (bestückt mit 2x 1,2GHZ, 256MB DDR2 RAM). Verbaut ist das Ding in einem Hostsystem basierend auf einem Tyan Mainboard und einer AMD Phenom (4x 2,4GHz) CPU mit 8GB DDR2-800 RAM. Am RAID-Controller sind 4 Stk 150GB Western Digital VeloCity angeschlossen.

Die Logik (meine zumindest) sagt nun: nativer RAID-Controller mit eigener XOR-Einheit und dediziertem RAM muss beim Datendurchsatz eines RAID5 schneller sein, als ein Software RAID, das über die Host-CPU, den Host-RAM und die OnBoard-SATA-Schnittstellen läuft. Soweit die Theorie. Fakt ist jedoch, dass das Software-RAID (mit Debian Linux gebastelt – RAID5 mit 16k Clustergröße) um über 100MB/s Peak (SW-RAID Peak: 361MB/s vs. HW-RAID Peak: 259MB/s) schneller ist, als das Hardware-RAID.

Wozu habe ich 250Eur netto für den RAID-Controller investiert 😯 ? Ja ja, nativer Support, Host-unabhängig, Disaster Recovery, etc. Ist ja alles klar und spricht FÜR den Adaptec Controller. Aber bei gerade diesem einen System wäre es extrem auf den Datendurchsatz angekommen *seufz*. Ich baue das jetzt nochmal mit 32k Clustergröße und wenn ich dann keinen merkbaren Unterschied zugunsten des Adapatec-Controllers feststellen kann, dann lasse ich es drauf ankommen und bestelle auch noch einen 3Ware-Controller und teste weiter :(.

Transporter 3, Kino und Kommerz …

Am Freitag waren wir im Kino und haben uns Transporter 3 angesehen (die ersten beiden Teile waren ja wirklich der Hammer!). Im dritten Teil gab es dann den eigentlichen Höhenpunkt (den man aus den beiden ersten Teilen kannte) nicht mehr – nein, die Spannung zog sich über den gesamten Film und immer wieder gab es gut gemachte, aber sehr unrealistische Actionszenen. In den beiden ersten Teilen hielt sich das noch so alles im Rahmen und ja, es gab sicher auch die eine oder andere Szene die absurd war, aber im dritten Teil haben es die Macher total übertrieben.

Zum einen wird es als selbstverständlich dargestellt, dass Frank weiterhin den Audi A8 W12 aus dem zweiten Teil weiterfährt, zum anderen wird er aber permanent von einer popeligen Mercedes E-Klasse eingeholt, die nicht als AMG Modell gekennzeichnet ist – entweder hätte man hier auf den S8 zurückgreifen sollen oder den Mercedes durch einen 3er BMW ersetzen sollen – SO passt das Bild jedenfalls nicht zusammen. Weiters ist es natürlich selbstverständlich, dass man die Kiste durch hin und herschleudern mit ~200 km/h (laut Tacho) auf 2 Räder gestellt bekommt – ohne Überschlag wohl gemerkt ;).

Ach, was jammere ich rum: der dritte Teil wurde schlicht und ergreifend für die breite Masse tauglich gemacht – Teil 1 war sowieso nur für jene, die auf Autofilme standen, Teil 2 war auch schon eher Massenschrott und Teil 3: danke, aber erstens zu wenig detailierte Actionszenen und zum anderen: Liebesklimbim passt einfach nicht zu Frank Martin (Jason Statham)!